using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<token>""[^""]+""\s*:\s*)(?:\d*[^\d:][^:]*:)*(?<number>\d+)(?::[^:]*)*$";
string substitution = @"$1$2";
string input = @"""number"":4aac4c35-8e3e-4730-8364-381884d6f20f:DA:OPAS:117804471:PAN:false";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}