const regex = new RegExp('^(?!Vol)(?!Chapter)(?<Series>.+?)(-|_|\\s|#)\\d+(-\\d+\\b)?(.+?(?=\\s+->))?', 'gm')
const str = `Test cases:
Kodoja #001 (March 2016) -> Kodoja
Bleach 001-002 -> Bleach
[BAA]_Darker_than_Black_Omake-1 -> [BAA]_Darker_than_Black_Omake
Edge cases:
The Archmage Returns After 4000 Years -> The Archmage Returns After
See You in My 19th Life -> See You in My
The Return of the 8th Class Mage -> The Return of the
Kaiju No. 8 -> Kaiju No.
Zom 100 - Bucket List of the Dead -> Zom`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}