$re = '/^(?!Vol)(?!Chapter)(?<Series>.+?)(-|_|\s|#)\d+(-\d+\b)?(.+?(?=\s+->))?/m';
$str = 'Test cases:
Kodoja #001 (March 2016) -> Kodoja
Bleach 001-002 -> Bleach
[BAA]_Darker_than_Black_Omake-1 -> [BAA]_Darker_than_Black_Omake
Edge cases:
The Archmage Returns After 4000 Years -> The Archmage Returns After
See You in My 19th Life -> See You in My
The Return of the 8th Class Mage -> The Return of the
Kaiju No. 8 -> Kaiju No.
Zom 100 - Bucket List of the Dead -> Zom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);