import re
regex = re.compile(r"^(?!Vol)(?!Chapter)(?<Series>.+?)(-|_|\s|#)\d+(-\d+\b)?(.+?(?=\s+->))?", flags=re.MULTILINE)
test_str = ("Test cases:\n"
"Kodoja #001 (March 2016) -> Kodoja\n"
"Bleach 001-002 -> Bleach\n"
"[BAA]_Darker_than_Black_Omake-1 -> [BAA]_Darker_than_Black_Omake\n\n"
"Edge cases:\n"
"The Archmage Returns After 4000 Years -> The Archmage Returns After\n"
"See You in My 19th Life -> See You in My\n"
"The Return of the 8th Class Mage -> The Return of the\n"
"Kaiju No. 8 -> Kaiju No.\n"
"Zom 100 - Bucket List of the Dead -> Zom")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")