use strict;
my $str = 'Test cases:
Kodoja #001 (March 2016) -> Kodoja
Bleach 001-002 -> Bleach
[BAA]_Darker_than_Black_Omake-1 -> [BAA]_Darker_than_Black_Omake
Edge cases:
The Archmage Returns After 4000 Years -> The Archmage Returns After
See You in My 19th Life -> See You in My
The Return of the 8th Class Mage -> The Return of the
Kaiju No. 8 -> Kaiju No.
Zom 100 - Bucket List of the Dead -> Zom';
my $regex = qr/^(?!Vol)(?!Chapter)(?<Series>.+?)(-|_|\s|#)\d+(-\d+\b)?(.+?(?=\s+->))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}