#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxi)^(" & @CRLF & _
" \s*" & @CRLF & _
" | .* \s .*" & @CRLF & _
" | (?:undefined|null|nan|infinity|true|false)" & @CRLF & _
" | (?:test(?:ing)?|example|guest|anonymous|anon|user|visitor|n/?a)" & @CRLF & _
" | \[object \s [^\]]+ \]" & @CRLF & _
" | [-._+/=:@~]+" & @CRLF & _
" | [A-Za-z0-9._\-+/=:@~]{,2}" & @CRLF & _
" | [A-Za-z0-9._\-+/=:@~]{256,}" & @CRLF & _
")$"
Local $sString = "valid-id@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")