const regex = new RegExp('^(
\\s*
| .* \\s .*
| (?:undefined|null|nan|infinity|true|false)
| (?:test(?:ing)?|example|guest|anonymous|anon|user|visitor|n/?a)
| \\[object \\s [^\\]]+ \\]
| [-._+/=:@~]+
| [A-Za-z0-9._\\-+/=:@~]{,2}
| [A-Za-z0-9._\\-+/=:@~]{256,}
)$', 'gmi')
const str = `valid-id@example.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}