import re
regex = re.compile(r"""
^(
\s*
| .* \s .*
| (?:undefined|null|nan|infinity|true|false)
| (?:test(?:ing)?|example|guest|anonymous|anon|user|visitor|n/?a)
| \[object \s [^\]]+ \]
| [-._+/=:@~]+
| [A-Za-z0-9._\-+/=:@~]{,2}
| [A-Za-z0-9._\-+/=:@~]{256,}
)$
""", flags=re.MULTILINE | re.VERBOSE | re.IGNORECASE)
test_str = "valid-id@example.com"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")