package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(
\s*
| .* \s .*
| (?:undefined|null|nan|infinity|true|false)
| (?:test(?:ing)?|example|guest|anonymous|anon|user|visitor|n/?a)
| \[object \s [^\]]+ \]
| [-._+/=:@~]+
| [A-Za-z0-9._\-+/=:@~]{,2}
| [A-Za-z0-9._\-+/=:@~]{256,}
)$`)
var str = `valid-id@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}