package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<a .*?</a>(*SKIP)(*F)|\bapple\b`)
var str = `Lorem ipsum apple sit amet, consectetur <a href="#">apple</a> elit <a href=
"/test/apple">lorem</a> another apple here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}