// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)<a .*?</a>(*SKIP)(*F)|\bapple\b").unwrap();
let string = "Lorem ipsum apple sit amet, consectetur <a href=\"#\">apple</a> elit <a href=
\"/test/apple\">lorem</a> another apple here";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}