const regex = new RegExp('(?is)<a .*?</a>(*SKIP)(*F)|\\bapple\\b', 'g')
const str = `Lorem ipsum apple sit amet, consectetur <a href="#">apple</a> elit <a href=
"/test/apple">lorem</a> another apple here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}