import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?is)<a .*?</a>(*SKIP)(*F)|\\bapple\\b";
final String string = "Lorem ipsum apple sit amet, consectetur <a href=\"#\">apple</a> elit <a href=\n"
+ "\"/test/apple\">lorem</a> another apple here";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}