re = /(?is)<a .*?<\/a>(*SKIP)(*F)|\bapple\b/
str = 'Lorem ipsum apple sit amet, consectetur <a href="#">apple</a> elit <a href=
"/test/apple">lorem</a> another apple here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end