$re = '~(?is)<a .*?</a>(*SKIP)(*F)|\bapple\b~';
$str = 'Lorem ipsum apple sit amet, consectetur <a href="#">apple</a> elit <a href=
"/test/apple">lorem</a> another apple here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);