#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-2]\.\d+\.\d+$)|(3\.0\.\d+$)|(3\.1\.\d$)|(3\.1\.1[1-6]$)"
Local $sString = "" & @CRLF & _
"1.1.17" & @CRLF & _
"1.999.99" & @CRLF & _
"2.0.0" & @CRLF & _
"2.1.17" & @CRLF & _
"2.999.99" & @CRLF & _
"3.1.16" & @CRLF & _
"3.1.16" & @CRLF & _
"3.0.17" & @CRLF & _
"3.1.17"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")