using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-2]\.\d+\.\d+$)|(3\.0\.\d+$)|(3\.1\.\d$)|(3\.1\.1[1-6]$)";
string input = @"
1.1.17
1.999.99
2.0.0
2.1.17
2.999.99
3.1.16
3.1.16
3.0.17
3.1.17";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}