// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-2]\.\d+\.\d+$)|(3\.0\.\d+$)|(3\.1\.\d$)|(3\.1\.1[1-6]$)").unwrap();
let string = "
1.1.17
1.999.99
2.0.0
2.1.17
2.999.99
3.1.16
3.1.16
3.0.17
3.1.17";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}