$re = '/^([0-2]\.\d+\.\d+$)|(3\.0\.\d+$)|(3\.1\.\d$)|(3\.1\.1[1-6]$)/m';
$str = '
1.1.17
1.999.99
2.0.0
2.1.17
2.999.99
3.1.16
3.1.16
3.0.17
3.1.17';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);