import re
regex = re.compile(r"^([0-2]\.\d+\.\d+$)|(3\.0\.\d+$)|(3\.1\.\d$)|(3\.1\.1[1-6]$)", flags=re.MULTILINE)
test_str = ("\n"
"1.1.17\n"
"1.999.99\n"
"2.0.0\n"
"2.1.17\n"
"2.999.99\n"
"3.1.16\n"
"3.1.16\n"
"3.0.17\n"
"3.1.17")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")