# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s*--.*)(,?)$//gm;t' <<< "-- Input
Part of a String -- Additional Text
String without Token
Another String with Text -- Some More Text
String with 1 - is fine
String with\-\- is fine
But String with -- Is shortened"