package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s*--.*)(,?)$`)
var str = `-- Input
Part of a String -- Additional Text
String without Token
Another String with Text -- Some More Text
String with 1 - is fine
String with\-\- is fine
But String with -- Is shortened`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}