import Foundation
let pattern = #"(\s*--.*)(,?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-- Input
Part of a String -- Additional Text
String without Token
Another String with Text -- Some More Text
String with 1 - is fine
String with\-\- is fine
But String with -- Is shortened
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)