const regex = /(\s*--.*)(,?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s*--.*)(,?)$', 'gm')
const str = `-- Input
Part of a String -- Additional Text
String without Token
Another String with Text -- Some More Text
String with 1 - is fine
String with\\-\\- is fine
But String with -- Is shortened`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);