use strict;
my $str = '-- Input
Part of a String -- Additional Text
String without Token
Another String with Text -- Some More Text
String with 1 - is fine
String with\\-\\- is fine
But String with -- Is shortened';
my $regex = qr/(\s*--.*)(,?)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";