using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s*--.*)(,?)$";
string substitution = @"";
string input = @"-- Input
Part of a String -- Additional Text
String without Token
Another String with Text -- Some More Text
String with 1 - is fine
String with\-\- is fine
But String with -- Is shortened";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}