#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/.+?(foo\.com)[^\/]+(?<data>(\/[^\/]+){2}\/)"
Local $sString = "http://www.foo.com:80/main.html" & @CRLF & _
"http://www.foo.com:80/xe/journal/v1/book/nF1.jpg" & @CRLF & _
"http://www.foo.com:80/xeeee1232131/journal/v1/book/nF1.jpg" & @CRLF & _
"http://www.foo.com:80/xeeee/journal/v1/book/nF1.jpg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")