import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/.+?(foo\\.com)[^\\/]+(?<data>(\\/[^\\/]+){2}\\/)";
final String string = "http://www.foo.com:80/main.html\n"
+ "http://www.foo.com:80/xe/journal/v1/book/nF1.jpg\n"
+ "http://www.foo.com:80/xeeee1232131/journal/v1/book/nF1.jpg\n"
+ "http://www.foo.com:80/xeeee/journal/v1/book/nF1.jpg\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}