using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/.+?(foo\.com)[^\/]+(?<data>(\/[^\/]+){2}\/)";
string input = @"http://www.foo.com:80/main.html
http://www.foo.com:80/xe/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee1232131/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee/journal/v1/book/nF1.jpg
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}