use strict;
my $str = 'http://www.foo.com:80/main.html
http://www.foo.com:80/xe/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee1232131/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee/journal/v1/book/nF1.jpg
';
my $regex = qr/https?:\/\/.+?(foo\.com)[^\/]+(?<data>(\/[^\/]+){2}\/)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}