// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/.+?(foo\.com)[^\/]+(?<data>(\/[^\/]+){2}\/)").unwrap();
let string = "http://www.foo.com:80/main.html
http://www.foo.com:80/xe/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee1232131/journal/v1/book/nF1.jpg
http://www.foo.com:80/xeeee/journal/v1/book/nF1.jpg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}