#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<=\s)[A-z]+|(?<=\.)[A-z\s]+)(?=\?)"
Local $sString = "Can you detect this?" & @CRLF & _
"Ok smarty pants, how about THIS?" & @CRLF & _
"Oh you're good...T H I S?" & @CRLF & _
"Dammit!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")