re = /((?<=\s)[A-z]+|(?<=\.)[A-z\s]+)(?=\?)/m
str = 'Can you detect this?
Ok smarty pants, how about THIS?
Oh you\'re good...T H I S?
Dammit!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end