using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\s)[A-z]+|(?<=\.)[A-z\s]+)(?=\?)";
string input = @"Can you detect this?
Ok smarty pants, how about THIS?
Oh you're good...T H I S?
Dammit!
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}