const regex = /((?<=\s)[A-z]+|(?<=\.)[A-z\s]+)(?=\?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=\\s)[A-z]+|(?<=\\.)[A-z\\s]+)(?=\\?)', 'gm')
const str = `Can you detect this?
Ok smarty pants, how about THIS?
Oh you're good...T H I S?
Dammit!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}