$re = '/((?<=\s)[A-z]+|(?<=\.)[A-z\s]+)(?=\?)/m';
$str = 'Can you detect this?
Ok smarty pants, how about THIS?
Oh you\'re good...T H I S?
Dammit!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);