package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"]+?)\s+\|\s+([^"]+?)"`)
var str = `"Hello"|"Green | Blue"|123.45|""|""|""|5|45`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}