$re = '/"([^"]+?)\s+\|\s+([^"]+?)"/m';
$str = '"Hello"|"Green | Blue"|123.45|""|""|""|5|45';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;