use strict;
my $str = '"Hello"|"Green | Blue"|123.45|""|""|""|5|45';
my $regex = qr/"([^"]+?)\s+\|\s+([^"]+?)"/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";