re = /"([^"]+?)\s+\|\s+([^"]+?)"/m
str = '"Hello"|"Green | Blue"|123.45|""|""|""|5|45'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result