# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[A-Za-z]+\s?)*)-in-((?:[A-Za-z]+\s?)*)(\.[\w]{3,4})?/${1}-${2}${3}/gm;t' <<< "Sammi Tye-in-Beauty.mp4
Tye-in-Classic Curves.mp4
Sammi Tye-in-Classy Erotica.mp4
Sammi Tye-in-Classy Erotica"