$re = '/((?:[A-Za-z]+\s?)*)-in-((?:[A-Za-z]+\s?)*)(\.[\w]{3,4})?/m';
$str = 'Sammi Tye-in-Beauty.mp4
Tye-in-Classic Curves.mp4
Sammi Tye-in-Classy Erotica.mp4
Sammi Tye-in-Classy Erotica';
$subst = "${1}-${2}${3}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;