// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:[A-Za-z]+\s?)*)-in-((?:[A-Za-z]+\s?)*)(\.[\w]{3,4})?").unwrap();
let string = "Sammi Tye-in-Beauty.mp4
Tye-in-Classic Curves.mp4
Sammi Tye-in-Classy Erotica.mp4
Sammi Tye-in-Classy Erotica";
let substitution = "${1}-${2}${3}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}