use strict;
my $str = 'Sammi Tye-in-Beauty.mp4
Tye-in-Classic Curves.mp4
Sammi Tye-in-Classy Erotica.mp4
Sammi Tye-in-Classy Erotica';
my $regex = qr/((?:[A-Za-z]+\s?)*)-in-((?:[A-Za-z]+\s?)*)(\.[\w]{3,4})?/mp;
my $subst = '${1}-${2}${3}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";