#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:[A-Za-z]+\s?)*)-in-((?:[A-Za-z]+\s?)*)(\.[\w]{3,4})?"
Local $sString = "Sammi Tye-in-Beauty.mp4" & @CRLF & _
"Tye-in-Classic Curves.mp4" & @CRLF & _
"Sammi Tye-in-Classy Erotica.mp4" & @CRLF & _
"Sammi Tye-in-Classy Erotica"
Local $sSubst = "${1}-${2}${3}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)