import Foundation
let pattern = #"((?:[A-Za-z]+\s?)*)-in-((?:[A-Za-z]+\s?)*)(\.[\w]{3,4})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Sammi Tye-in-Beauty.mp4
Tye-in-Classic Curves.mp4
Sammi Tye-in-Classy Erotica.mp4
Sammi Tye-in-Classy Erotica
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1}-${2}${3}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)