#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Jan|Fev|Ma[ri]|Abr|Ju[ln]|Ago|Set|Out|Nov|Dez)\/(Se[gx]|Ter|Qu[ai]|Sab|Dom)$"
Local $sString = "Jan/Seg" & @CRLF & _
"Fev/Ter" & @CRLF & _
"Mar/Qua" & @CRLF & _
"Abr/Qui" & @CRLF & _
"Mai/Sex" & @CRLF & _
"Jun/Sab" & @CRLF & _
"Jul/Dom" & @CRLF & _
"Ago/Seg" & @CRLF & _
"Set/Ter" & @CRLF & _
"Out/Qua" & @CRLF & _
"Nov/Qui" & @CRLF & _
"Dez/Sex" & @CRLF & _
"dez/sab" & @CRLF & _
"Abc/Def"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")