import re
regex = re.compile(r"^(Jan|Fev|Ma[ri]|Abr|Ju[ln]|Ago|Set|Out|Nov|Dez)\/(Se[gx]|Ter|Qu[ai]|Sab|Dom)$", flags=re.MULTILINE)
test_str = ("Jan/Seg\n"
"Fev/Ter\n"
"Mar/Qua\n"
"Abr/Qui\n"
"Mai/Sex\n"
"Jun/Sab\n"
"Jul/Dom\n"
"Ago/Seg\n"
"Set/Ter\n"
"Out/Qua\n"
"Nov/Qui\n"
"Dez/Sex\n"
"dez/sab\n"
"Abc/Def")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")