$re = '/^(Jan|Fev|Ma[ri]|Abr|Ju[ln]|Ago|Set|Out|Nov|Dez)\/(Se[gx]|Ter|Qu[ai]|Sab|Dom)$/m';
$str = 'Jan/Seg
Fev/Ter
Mar/Qua
Abr/Qui
Mai/Sex
Jun/Sab
Jul/Dom
Ago/Seg
Set/Ter
Out/Qua
Nov/Qui
Dez/Sex
dez/sab
Abc/Def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);