import Foundation
let pattern = #"^(Jan|Fev|Ma[ri]|Abr|Ju[ln]|Ago|Set|Out|Nov|Dez)\/(Se[gx]|Ter|Qu[ai]|Sab|Dom)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Jan/Seg
Fev/Ter
Mar/Qua
Abr/Qui
Mai/Sex
Jun/Sab
Jul/Dom
Ago/Seg
Set/Ter
Out/Qua
Nov/Qui
Dez/Sex
dez/sab
Abc/Def
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)